Notes Sections:
  1. EIGRP Overview and Neighbor Relationships
  2. EIGRP Topology, Routes and Convergence
  3. EIGRP Route Summarization and Filtering
  4. OSPF Overview and Neighbor Relationships
  5. OSPF Topology, Routes and Convergence
  6. OSPF Route Summarization, Filtering and Default Routing
  7. OSPF Virtual Links and Frame Relay Operations
  8. Basic IGP Redistribution
  9. Advance IGP Redistribution
  10. Policy-Based Routing and IP Service Level Agreement
  11. Internet Connectivity and BGP
  12. External BGP
  13. Internal BGP and BGP Route Filtering
  14. BGP Path Control
  15. IPv6 Addressing
  16. IPv6 Routing Protocols and Redistribution
  17. IPv6 and IPv4 Coexistence
  18. Routing over Branch Internet Connections
  19. Misc

- EIGRP Overview and Neighbor Relationships Section 1. Top

* Enable EIGRP on the router and turning on interfaces with the network command:
     R1(config)# router eigrp "asn"
     R1(router-config)# network "wild-card-mask"
* The ASN must be the same in all routers for a given domain.

* Verification commands:
     R1# show ip eigrp interfaces
     R1# show ip protocols
     R1# show ip eigrp neighbors
     R1# show ip eigrp topology
     R1# show ip eigrp traffic
     R1# show ip route
* Neighbor Discovery.- EIGRP routers send Hello messages to discover potential neighbors and perform basic parameter checks to determine which routers should become nighbors.

* Topology Exchange.- Neighbors exchange full topology updates when the neighbor relationship comes up, and then only partial updates as needed based on changes to the network topology.

* Choosing Routes.- Each router analyzes their respective EIGRP topology tables, choosing the lowest-metric route to reach each subnet.

* Key tables used by EIGRP:
  • EIGRP neighbor table.
  • EIGRP topology table.
  • IP routing table.
* Update messages send topology information to neighbors.

* In LANs update messages are sent to multicast 224.0.0.10

* Update messages are send using RTP (Reliable Transport Protocol), this ensures guaranteed update delivery.

* By default, EIGRP only uses the bandwidth and delay settings when calculating route metric.

* EIGRP route metric formula:

EIGRP route metric formula
  • least-bandwidth.- Represents the lowest-bandwidth link in the route, using a unit of kilobits per second.
  • cumulative-delay.- The sum of all the delay values for all links in the route, with a unit of 10-microseconds.
* You can manually set the least-bandwidth and cumulative-delay by using the following commands:
     R1(config-if)# bandwidth...  //units in kbs
     R1(config-if)# delay...      //units in tens-of-microseconds
* Hello interval.- Indicates how often a router sends EIGRP Hello messages on an interface.

* Hold timer.- Indicates when a neighboring router has failed, based on a router not receiving any EIGRP messages, including Hellos, in this timer period. Defaults, 15-seconds wait for T1 or slower, 60-seconds for Frame-Relay.

* Manually setting Hello-interval and Hold-timer
     R1(config-if)# ip hello-interval eigrp "asn" "seconds"
     R1(config-if)# ip hold-time eigrp "asn" "seconds"
* Hello interval verification:
     R1# show ip eigrp interface detail "interface"
* Hold timer verification. Find it by seeing running configuration or by repeatedly issuing (look for Hold column):
     R1# show ip eigrp neighbors
* Passive Interface.- When an interface is passive, EIGRP does not send any EIGRP messages on the interface, multicast or unicast; and the router ignores any EIGRP messages received on the interface. However, EIGRP still advertises about the connected subnets if matched with an EIGRP network command.

* Passive Interface configuration:
     R1(config-router)# passive-interface "interface"
* All EIGRP interfaces default to be non passive, you can change this using the passive-interface default command, after issuing this command, all interfaces will be passive. Use the no passive-interface "interface" command to forward EIGRP messages in that interface:
     R1(config-router)# passive-interface default        //makes all interfaces passive
     R1(config-router)# no passive-interface "interface" //makes interface forward EIGRP messages
* Passive Interface verification: a) show ip eigrp interfaces omits passive interfaces. b) show ip protocols explicitly lists all passive interfaces.

* EIGRP authentication:
  • Authenticates every EIGRP message.
  • Routers must use the same PSK.
  • Helps prevent DoS.
  • Does not provide privacy.
  • If failed routers cannot become neighbors.
* EIGRP authentication configuration:
     R1(config)# key chain "name-for-keychain"
     R1(config-keychain)# key "key-number"        //must match with neighbor
     R1(config-keychain-key)# key-string "string" //must match with neighbor
     R1(config-keychain-key)# accept-lifetime "start-time" "end-time"|duration "secs"|infinite     //optional
     R1(config-keychain-key)# send-lifetime "start-time" "end-time"|duration "secs"|infinite       //optional
     
     R1(config-if)# ip authentication mode eigrp "asn" md5     //enable authentication on ain interface
     R1(config-if)# ip authentication key-chain eigrp "asn" "name-for-keychain"  //specify key chain
* EIGRP key chain time logic:
  • If no lifetime has been configured for a key, it is considered to be valid during all time frames.
  • Sending EIGRP messages.- Use the lowest key number among all currently valid keys.
  • Rceiving EIGRP messages.- Check the MD5 digest using all currently valid keys.
* NTP should be configured for production.

* EIGRP authentication verification: a) show ip eigrp neighbors, verifies nighbors remain up b) show key chain c) debug eigrp packet

* Static neighbors.- Help reduce multicasts; when configured on an interface, no dynamic neighbors can be formed or kept on that interface.

* Static neighbors configuration:
     R1(config-router)# neighbor "ip-address" "outgoing-interface"
* EIGRP K-values (Metric Components) configurartion:
     R1(config-router)# metric weights tos k1 k2 k3 k4 k5
  • tos.- This parameter only has one valid value, 0, and can be otherwise ignored.
  • k1.- Bandwidth modifier.
  • k2.- Load modifier.
  • k3.- Delay modifier.
  • k4.- Reliability modifier.
  • k5.- Additional reliability modifier
* k1 and k3 default to 1, all the others default to 0. Cisco recommends against using k2,k4 and k5.

* k-values must match before two routers become neighbors.

* EIGRP Router-ID.- The RID represents each router, it's a 32-bit number.

* EIGRP determines its RID when the process starts, using the same general rules as does OSPF:
  1. Use the manually configured value.
         R1(config-router)# eigrp router-id "x.x.x.x"
  2. Or, use the highest IPv4 address on an up/up loopback interface.
  3. Or, use the highest IPv4 address on an up/up physical interface.
* Neighboring over WANs
  • Frame Relay.-
  • MPLS VPN.-
  • Metro Ethernet.-

- EIGRP Topology, Routes and Convergence. Section 2. Top

* EIGRP Messages:
  • Hello
  • Update
  • Query
  • Reply
  • ACK
* EIGRP uses update and ack for topology data exchange. The update message contains topology information and the ack message acknowledges receipt of the update packet.

* The EIGRP update message contains the following information:
  • Prefix.
  • Prefix lenght.
  • Metric components: bandwidth, delay, reliability and load.
  • Nonmetric components: MTU and hop count.
* Use the following command to find out the bandwidth and delay for a given route:
     R1# show ip eigrp topology "x.x.x.x/x"
* The delay command, which lets you set the delay manually, along with the data stored in the EIGRP topology database, use a unit of tens-of-microseconds. However, the show interfaces and show ip eigrp topology commands list delay in a unit of microsecods.

* The EIGRP Update Process:
  • When a neighbor first comes up, the routers exchange full updates, meaning the routers exchange all topology information.
  • After all prefixes have been exchanged with a neighbor, the updates cease with that neighbor if no changes occur in the network. There is no periodic reflooding of topology data.
  • If something changes, the routers send partial updates about only the prefixes whose status or metric components have changed.
  • If neighbors fail and then recover, or new neighbor adjacencies are formed, full updates occur over these adjacencies.
  • EIGRP uses Split Horizon rules on most interfaces by default, which impacts exactly which topology data is sent during both full and partial updates.
* Disable Split Horizon to prevent EIGRP neighboring and route updating issues with Frame Relay multipoint interfaces. Use the following command:
     R1(config-if)# no ip split-horizon eigrp "asn"
* NOTE: The equivalent command for RIP is : R1(config-if)$ no ip slit-horizon

* By default, a router sends EIGRP messages out an interface but only up to 50% of the bandwidth defined on the interface with the bandwidth command. Use the following commnad to adjust this percentage:
     R1(config-if)# ip bandwidth-percent eigrp "asn" "percent"
  • The IOS default for bandwidth on serial interfaces and subinterfaces is 1544 Kbps.
  • Set the bandwidth of point-to-point links to the speed of the Committed Information Rate (CIR) of the single PVC on the subinterface.
  • Set the bandwidth of multipoint subinterfaces to around the total CIR for all VCs assigned to the subinterface.
  • For multipoint subinterfaces, IOS WAN bandwidth control first divides the subinterface bandwidth by the number of configured PVCs and then determines the EIGRP percentage based on that number.
* Feasible Distance (FD).- Used by the local router to choose the best route for a prefix. Calculated in the local router. Local router's prespective for a route.

* Reported Distance (RD).- Calculated in a neighbor router. Neighbor's prespective for a route. Used by the local router when converging to new routes.

* Routers use the FD to determine the best route, based on the lowest metric, and use the RD when falling back to an alternatvie route when the best route fails.

* If a design requires that you influence the choice of route by changing bandwidth or delay, setting the delay value is typically the better choice. Changing the bandwidth has a lot more side effects than just route selection.

* Common defaults for bandwidth and delay:

Interface Type
Bandwidth (kbps)
Delay (microseconds)
Serial 1544 20,000
GigE 1,000,000 10
FastE 100,000 100
Ethernet 10,000 1000


* EIGRP offset-list allows to manipulate the metric for a route, it adds an offset to a route's metric.
     R1(config-router)# offset-list "acl" in|out "offset" "interface"
* Successor.- The best route to reach a given prefix, the route with the smallest FD.

* Feasible Successor.- Loop-free backup route for the same prefix, stored in the topology table.

* A router determines if a route is a feasible successor based on the feasibility condition: "If a non-successor route's RD is less than the FD, the route is a feasible successor route."

* Use the following command to see the successor and feasible successors routes:
     R1# show ip eigrp topology
* Use the following command to see all links, including those that are neither successor nor feasible successor routes:
     R1# show ip eigrp topology all-links
* When a successor fails and a feasible succesor exists in the IEGRP topology database, EIGRP places that feasible successor route into the routing table. The elapsed time from noticing that the route failed, until the route is replaced, is typically less than 1 second.

* Routes for which the successor route fails, with no feasible successor routes, move to an active state (DUAL algorithm):
  • Change the state, as listed in the show ip eigrp topology command, from passive (p) to active (a).
  • Send EIGRP Query messages to every neighbor except the neighbor in the failed route. The query asks a neighbor whether that nighbor has a loop-free route for the listed prefix/length.
  • The neighbor considers itself to have a loop-free route if that neighbor is passive for that prefix/length. If so, the neighbor 1) sends an EIGRP Reply message, telling the original router that it does indeed have a loop-free route and 2) does not forward the Query.
  • If the neighbor itself is active on this route, that heighbor 1) floods EIGRP Query messages to its neighbors and 2) does not immediately send an EIGRP Reply back to the original router, instead waitng on replies to its own set of Query messages.
  • When a router has received Reply messages from all neighbors to which it sent any Query messages, that router can then send a Reply message to any of its neighbors as necessary.
  • When a router has received a Reply for all its Query messages, that router may safely use the best of the routes confirmed to be loop free.
* EIGRP sends every Query and Reply message using RTP, so every message is acknowledged using an EIGRP ACK message.

* In some cases, creating FS routes for all routes on all routers is impossible, so engineers should take action to limit the scope of queries.

* EIGRP defines stub routers as follows: "A router that should not forward traffic between two remote EIGRP learned subnets". Stub routers do not advertise EIGRP learned routes from one neighbor to other EIGRP neighbors. Additionally, nonstub routers note which EIGRP neighbors are stub routers, and the nonstub routers do not send Query messages to the stub routers. This action greatly reduces the scope of Query messages when a route goes active.

* Use the following command to configure an EIGRP stub router:
     R1(config-router)# eigrp stub connected|summary|static|redistributed|receive-only
* In addition to stub routers, route summarization also limits EIGRP Query scope and therefore improves convergence time.

* EIGRP sets a limit on how long it should take to receive all Reply messages by using the active timer, it's set to 3 minutes by default.

* The active timer can be changed for an entire EIGRP process using the following command:
     R1(config-router)# timers active-time "time"
* Routes for which a reouter does not receive a Reply within the active timer are considered to be Stuk-in-Active (SIA) routes.

* IOS allows routing protocols to place multiple routes with same metric into the routing table for an individual prefix/length. IOS then balances traffic across those routes, by default balancing traffic on a per-destination IP address basis. Use the following command to define the number of routes allows for each prefix/length:
     R1(config-router)# maximum-paths "number" //defaults to 4
* In EIGRP, calculating the exact same metric for different routes for the same prefix is statistically unlikely. EIGRP's metric often results in 8-to-10 digit integer metric.

* IOS includes the concept of EIGRP variance. Variance lets you tell the IOS that the EIGRP metrics can be close in value and still be considered worthy of being added to the routing table, you can define how close.

* Use the following command to configure variance:
     R1(config-router)# variance "multiplier"
* The variance command defines a multiplier (integer) between 1 and 128. The router then multiplies the variance times the successor route's FD (the metric of the best route to reach a subnet). Any FS routes whose metric is less than or equal to the product of the variance times the FD are considered to be equal routes and may be placed into the routing table, up to the number of routes defined by the maximum-paths command.

- EIGRP Route Summarization and Filtering. Section 3. Top

* EIGRP enables route filtering using the distribute-list router subcommand, this command can refer to either:
  • an standard access control list (ACL).
  • a prefix-list.
  • a route map.
* The preceding tools classify whether a route should be permitted to be send/received in an EIGRP Update or be denied (filtered), the distribute-list command also specifies the direction, outbound or inbound updates, and optionally the interface on which to filter updates.

Filtering by ACLs

* The ACL must match a route with a permit clause to then allow the route to be advertised, and match the route with a deny clause to filter the route.

* Use the following commands for configuration:
     R1(config)# access-list "ACL_num" deny "subnet_address subnet_wildmask"
     R1(config)# access-list "ACL_num" permit any
     R1(config)# router eigrp 1
     R1(config-router)# distribute-list "ACL_num" out //all interfaces
* Filter by interface:
     R1(config-router)# distribute-list "ACL_num" out "interface" //filtering per interface
Filtering by IP Prefix List

* IP Prefix List Concepts
  • Prefix-Lists allow to match two components of an IP route:
    • The route prefix (subnet)
    • The prefix length (subnet mask)
  • IP Prefix-Lists can examine both the prefix and the prefix length, and a range of prefixes or a range of prefix lengths.
  • Each entry in a Prefix-List has a permit or deny, which simple states if a route is not filtered (permit) or filtered (deny).
  • Prefix-List matching logic:
    1. The route's prefix must be within the range of addresses implied by the prefix / prefix-length parameters specified in the command. These parameters simple indicates a range of IP addresses; for example ip prefix-list barney deny 10.0.0.0/8 , this command implies any route that begins with 10 .
    2. The route's prefix length must match the range of prefixes implied by the ge (greater-than-or-equal-to) and le (less-than-or-equal-to) parameters, if specified in the command. If none is supplied, the prefix length must match the one specified in step 1 (/8)

      Prefix List Parameter (ge & le)
      Range of Prefix Length
      Neither conf-length must = route-length
      Both ge and le ge-value <= route-length <= le-value
      Only le conf-length <= route-length <= le-value
      Only ge ge-value <= route-length <= 32

  • IOS requires that the configured conf-length, ge and le values meet the following requirement: conf-length<= ge-value <= le-value . Otherwise the IOS rejects the command.
  • Like ACLs, Prefix Lists include an implied deny all at the end of the list.
* IP Prefix List Configuration:
     R1(config)# ip prefix-list "list_name" seq "seq_num" deny "x.x.x.x/x" ge "ge" le "le"
     R1(config)# ip prefix-list "list_name" seq "seq_num" permit 0.0.0.0/0 le 32       //matches all
     R1(config)# router eigrp 1
     R1(config-router)# distribute-list prefix "list_name" out
Filtering by Route Maps

* When referenced by the distribute-list command, IOS processes the commands in the route map sequentially, based on the sequence numbers in the commands.

* Once a particular route has been matched and determined to be either filtered (deny) or allowed to pass (permit), even if more route maps commands exist later in the list, IOS stops processing the route-map for that route.

* The route map can reference to an ACL or Prefix List (by using the match subcommand).
  • The filtering logic takes place in the route map.
  • The route map simply filters (deny) or not filters (permit) anything that is matched (permitted) by the ACL or Prefix List used. Routes that are denied by the ACL/Prefix List do match the route map.
* A route map includes an implied deny all clause at the end; to configure a permit all, use a route-map entry with a permit action, but without a mach subcommand.

* Route maps have several more options on the match subcommand as compared to what can be examined by ACLs and Prefix Lists. However, for the purpose of EIGRP route filtering, these options do not provide significant help in filtering routes.

* Route map configuration:
     R1(config)# route-map "route-map_name" permit|deny "seq_num"
     R1(config-route-map)# match ip address "ACL"|[prefix-list "prefix-list_name"] 
     R1(config)# router eigrp 1
     R1(config-router)# distribute-list route-map "route-map_name" out
Route Summarization (Manual)

* Route summarization works best when the subnet planning process considers route summarization.The main engineer assigning subnets can assign larger address blocks to one part of the topology. The engineers working with that part of the internetwork can break the address block into individual subnets as needed. At the edge of that part of the network, route summaries can be configured.

* EIGRP supports route summarization at any router, unlike OSPF, which requires that summarization be performed only at area border routers (ABR) or autonomous system border routers (ASBR).

* Benefits and trade-offs of route summarization:
  • Benefits
    • Smaller routing tables, while all destinations still reachable.
    • Reduces Query scope (EIGRP).
    • The summary has the metric of the best of the subnets (subordinate routes) being summarized.
  • Trade-offs
    • Can cause suboptimal routing.
    • Packets destined for inaccessible destinations will flow to the summarizing router before being discarded.
* A subordinate route is a route whose address range is inside the range of addresses defined by the summary route.

* When EIGRP advertises a summary route, the advertising router considers the summary route to be up and working unless all subordinate routes fail.

* Route summarization configuration:
     R1(config-if)# ip summary-address eigrp "asn" "prefix" "subnet_mask"
* IOS adds a default AD of 5 to a summary address.

Default Routes

* Advertising a static default route with EIGRP
  1. Create a static route default route using the ip route 0.0.0.0 0.0.0.0 s0/0 command.
  2. Inject this route into the EIGRP topology database, either using the network 0.0.0.0 command or by redistributing the static route.
* Configuring a default network
  1. On the router to which all traffic should be directed, identify a classful network that can be advertised into the EIGRP domain (a loopback can be used), and ensure that network is being advertised into EIGRP, typically using the network router subcommand.
  2. Configure that network as a default network using the global command ip default-network "network-number" . This command makes EIGRP flag the specified route as a candidate default route. As a result, each EIRGP router treats their route for this particular network also as if were a default route.

- OSPF Overview and Neighbor Relationships. Section 4. Top

* OSPF uses link state logic, which can be broken into three major branches:
  • Neighbor discovery
  • Topology database exchange
  • Route computation (SPF algorithm), each router independently analyzes the topology data to choose the best routes from their perspective.
* OSPF requires more planning than does EIGRP, particularly with regard to the necessity for a hierarchical design using OSPF areas.

* Each router interface exists in a single area, with some special routers called area border routers (ABR), being the boundary btween areas.

* Inside an area, routers exchange detailed topology information. However, the detailed topology inofrmation does not flow between areas. Instead, the ABRs advertise briefer information between areas, incluiding information about subnets/masks, but the information advertised into one area does not include details about the topology of other area.

* One area, called the backbone area, must connect to all other areas. Packets that need to pass between two nonbackbone areas must pass through (at least) one backbone router. The ABRs must keep a copy of the LSDB for each area to which they attach. However, the ABRs do not forward all the topology details between areas, instead, they simply advertise the subnets (prefix/length) between the areas.

* Comon OSPF terms:
  1. Link state database.- The data structure held by an OSPF router for the purpose of storing topology data.
  2. Shortest Path First (SPF).- The name of the algorithm OSPF uses to analyze the LSDB. The analysis determines the best (lowest cost) route for each prefix/length.
  3. Link State Update (LSU).- The name of the OSPF packet that holds the detailed topology information, specifically LSAs.
  4. Link State Advertisement (LSA).- The name of a class of OSPF data structures that hold topology information. LSAs are held in memory in the LSDB and communicated over the network in LSU messages.
  5. Area.- A contiguous grouping of routers and router interfaces. Routers in an area strive to learn all topology information about the area, but they do not learn topology information about areas to which they do not connect.
  6. Area Border Router (ABR).- A router that has interfaces connected to at least two different OSPF areas, including the backbone area. ABRs hold topology data for each area, and calculate routes for each area, and advertise about those routes between areas.
  7. Backbone router.- Any router that has at least one interface connected to the backbone area.
  8. Internal router.- A router that has interfaces connected to only one area, making the router completely internal to that area.
  9. Designated Router (DR).- On multiaccess data links like LANs, an OSPF router elected by the routers on that data link to perform special functions. These functions include the generation of LSAs representing the subnet, and playing a key role in the database exchange process.
  10. Backup Designated Router (BDR).- A router on a multiaccess data link that monitors the DR and becomes prepared to take over for the DR, should the DR fail.
* OSPF uses the same logic as does EIGRP to choose a router-id on each router.

* OSPF basic configuration:
     R1(config)# router ospf "process-id" //the process-id DOES NOT have to match between routers
     R1(config-router)# network "subnet" "wildcard-mask" area "area-id" //the area id must match for neighborship
* Common OSPF verification commands:
  • Lists the interfaces on which OSPF is enabled (based on the network command); it omits passive interfaces.
         R1# show ip ospf interface brief
  • Lists the contents of the network configuration commands for each routing process, and a list of enabled but passive interfaces.
         R1# show ip protocols
  • Lists known neighbors, including neighbor state; does not list neighbors for which some mismatched parameter is preventing a valid OSPF neighbor relationship.
         R1# show ip ospf neighbors
  • Lists all LSAs for all connected areas.
         R1# show ip ospf database
  • Lists the contents of the IP routing table, listing OSPF learned routes with a code O .
         R1# show ip route
* Route tags.- Allows OSPF to tag routes as they are redistributed into OSPF. Also supported by EIGRP.

* Next-hop field.- Supports the advertisement of routes with a different next-hop router than the advertising router. Also supported by EIGRP.

* OSPF Neighbors and Adjacencies on LANs
  • OSPF must be enabled on the interface, either using the network router mode subcommand or the ip ospf area interface subcomand.
  • Passive interfaces are supported (Same as EIGRP).
* Items seen in OSPF Hello messages:
  • OSPF Router ID
  • Stub area flag
  • Interface specific settings:
    • Hello interval
    • Dead interval
    • Subnet mask
    • List of neighbors reachable on the interface
    • Area ID
    • Router priority
    • Designated Router (DR) IP address
    • Backup DR (BDR) IP address
    • Authentication digest
* Optimizing convergence using Hello and Dead timers:
  • Adjusting the Hello interval (automatically increases the Dead timer 4x )
         R1(config)# interface fa0/0
         R1(config-if)# ip ospf hello-interval 9
  • Manually setting the Dead timer
         R1(config-if)# ip ospf dead-interval "value"
* Manually setting the Router ID (must me unique):
		R1(config-router)# router-id "x.x.x.x"
* Manually setting the MTU (must be the same in same data link):
     R1(config)# interface fa0/0
     R1(config-if)# ip mtu "value" //Only IP
     R1(config-if)# mtu "value"    //All layer 3 protocols
* OSPF Authentication (MD5)
  1. Enable authentication
         R1(config-router)# area "area_num" authentication message-digest //all interfaces in area
         //OR:     
         R1(config-if)# ip ospf authentication message-digest //per interface
  2. Specify password
         R1(config-if)# ip ospf message-digest-key "key_num" md5 "key_value"
* OSPF Network Types

Interface Type
Uses DR/BDR?
Default Hello Interval
Dynamic Discovery of Neighbors?
More than two routers allowed in subnet?
Broadcast1
Yes
10
Yes
Yes
Point-to-point2
No
10
Yes
No
Nonbroadcast (NBMA)3
Yes
30
No
Yes
Point-to-multipoint
No
30
Yes
Yes
Point-to-multipoint nonbroadcast
No
30
No
Yes
1Default on LANs
2Default on Frame Relay point-to-point subinterfaces.
3Default on Frame Relay physical and multipoint subinterfaces.

* Changing OSPF network type
     R1(config-if)# ip ospf "network_type" | ?
* Manual neighbor configuration in OSPF router subcommand
     R1(config-router)# neighbor "ip_address"
* Neighborship over Frame Relay Point-to-Point subinterfaces

* Neighborship on MPLS VPN

* Neighborship on Metro-E

- OSPF Topology, Routes and Convergence. Section 5. Top

- OSPF Route Summarization, Filtering and Default Routing. Section 6. Top

- OSPF Virtual Links and Frame Relay Operations. Section 7. Top

- Basic IGP Redistribution. Section 8. Top

- Advance IGP Redistribution. Section 9. Top

- Policy-Based Routing and IP Service Level Agreement. Section 10. Top

- Internet Connectivity and BGP. Section 11. Top

- External BGP. Section 12. Top

- Internal BGP and BGP Route Filtering. Section 13. Top

- BGP Path Control. Section 14. Top

- IPv6 Addressing. Section 15. Top

- IPv6 Routing Protocols and Redistribution. Section 16. Top

- IPv6 and IPv4 Coexistence. Section 17. Top

- Routing over Branch Internet Connections. Section 18. Top

- Miscellaneous. Section 19. Top

* CH10 commands
     R1(config-router)# redistribute ...
     R1(config-router)# distribute-list ...
     R1(config-router)# distance ...
     R1(config)# route-map ...
     R1(config)# ip prefix-list ...

 

 

 

2024 By Angel Cool